Back to search

Apple Java security update for CVE-2010-0094

Severity CVSS Published Added Modified
8 (AV:N/AC:L/Au:N/C:P/I:P/A:P) April 01, 2010 January 26, 2012 December 05, 2013

Available Exploits 

Description

Unspecified vulnerability in the Java Runtime Environment component in Oracle Java SE and Java for Business 6 Update 18 and 5.0 Update 23 allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors. NOTE: the previous information was obtained from the March 2010 CPU. Oracle has not commented on claims from a reliable researcher that this is due to missing privilege checks during deserialization of RMIConnectionImpl objects, which allows remote attackers to call system-level Java functions via the ClassLoader of a constructor that is being deserialized.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

  • Upgrade to Apple Java version 1.5.0.24

    Upgrade your copy of Apple Java to 1.5.0.24 by selecting 'Software Update' from the Apple menu, or by using the softwareupdate utility.

  • Upgrade to Apple Java version 1.6.0.20

    Upgrade your copy of Apple Java to 1.6.0.20 by selecting 'Software Update' from the Apple menu, or by using the softwareupdate utility.

Related Vulnerabilities