Back to search

Java CPU February 2013 Java Runtime Environment CORBA vulnerability (CVE-2013-1475)

Severity CVSS Published Added Modified
10 (AV:N/AC:L/Au:N/C:C/I:C/A:C) February 01, 2013 February 03, 2013 December 12, 2013

Description

Unspecified vulnerability in the Java Runtime Environment (JRE) component in Oracle Java SE 7 through Update 11, 6 through Update 38, 5.0 through Update 38, and 1.4.2_40 and earlier, and OpenJDK 6 and 7, allows remote attackers to affect confidentiality, integrity, and availability via vectors related to CORBA. NOTE: the previous information is from the February 2013 CPU. Oracle has not commented on claims from another vendor that this issue is related to "IIOP type reuse management" in ObjectStreamClass.java.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

  • Oracle JRE >= 1.4.0.0 and < 1.4.2.41

    Upgrade to Oracle Java version 1.4.2.41

    Upgrade your copy of the Java Runtime Environment to 1.4.2.41, which can be downloaded from here. Note that this version requires Oracle Java SE Support, otherwise it is recommended to upgrade to the latest public JRE.

  • Oracle JRE >= 1.5.0.0 and < 1.5.0.39

    Upgrade to Oracle Java version 1.5.0.39

    Upgrade your copy of the Java Runtime Environment to 1.5.0.39, which can be downloaded from here. Note that this version requires Oracle Java SE Support, otherwise it is recommended to upgrade to the latest public JRE.

  • Oracle JRE >= 1.6.0.0 and < 1.6.0.39

    Upgrade to Oracle Java version 1.6.0.39

    Upgrade your copy of the Java Runtime Environment to 1.6.0.39, which can be downloaded from here.

  • Oracle JRE >= 1.7.0.0 and < 1.7.0.12

    Upgrade to Oracle Java version 1.7.0.12

    Upgrade your copy of the Java Runtime Environment to 1.7.0.12, which can be downloaded from here.

Related Vulnerabilities