Back to search

RHSA-2010:0408: java-1.4.2-ibm security update

Severity CVSS Published Added Modified
9 (AV:N/AC:M/Au:N/C:C/I:C/A:C) November 04, 2009 May 12, 2010 September 06, 2015

Available Exploits 


The IBM 1.4.2 SR13-FP4 Java release includes the IBM Java 2 RuntimeEnvironment and the IBM Java 2 Software Development Kit.This update fixes various vulnerabilities in the IBM Java 2 RuntimeEnvironment and the IBM Java 2 Software Development Kit. Thesevulnerabilities are summarized on the IBM "Security alerts" page listed inthe References section. (CVE-2009-3555, CVE-2009-3867, CVE-2009-3869,CVE-2009-3871, CVE-2009-3874, CVE-2009-3875)For the CVE-2009-3555 issue, this update disables renegotiation in thenon-default IBM JSSE2 provider for the Java Secure Socket Extension (JSSE)component. The default JSSE provider is not updated with this fix. Refer tothe IBMJSSE2 Provider Reference Guide, linked to in the References, forinstructions on how to configure the IBM Java 2 Runtime Environment to usethe JSSE2 provider by default.When using the JSSE2 provider, unsafe renegotiation can be re-enabled usingthe property. Refer to the followingKnowledgebase article for details: Do not install these java-1.4.2-ibm packages for SAP alongside thejava-1.4.2-ibm packages from the Red Hat Enterprise Linux Extras orSupplementary channels on the Red Hat Network. Doing so could cause yoursystem to fail to update cleanly, among other possible problems.All users of java-1.4.2-ibm for Red Hat Enterprise Linux 4 and 5 for SAPare advised to upgrade to these updated packages, which contain the IBM1.4.2 SR13-FP4 Java release. All running instances of IBM Java must berestarted for this update to take effect.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now




Related Vulnerabilities