Back to search

USN-1358-1: PHP vulnerabilities

Severity CVSS Published Added Modified
8 (AV:N/AC:L/Au:N/C:P/I:P/A:P) February 10, 2012 May 06, 2013 December 05, 2013

Available Exploits 

Description

The php_register_variable_ex function in php_variables.c in PHP 5.3.9 allows remote attackers to execute arbitrary code via a request containing a large number of variables, related to improper handling of array variables. NOTE: this vulnerability exists because of an incorrect fix for CVE-2011-4885.

Free Nexpose Download

Discover, prioritize, and remediate security risks today!

 Download now

References

Solution

  • php5-cli on Ubuntu Linux 10.04

    Upgrade php5-cli for Ubuntu 10.04 LTS

    Use `apt-get upgrade` to upgrade php5-cli to the latest version

  • php5-cgi on Ubuntu Linux 10.04

    Upgrade php5-cgi for Ubuntu 10.04 LTS

    Use `apt-get upgrade` to upgrade php5-cgi to the latest version

  • php5-common on Ubuntu Linux 10.04

    Upgrade php5-common for Ubuntu 10.04 LTS

    Use `apt-get upgrade` to upgrade php5-common to the latest version

  • php5-xsl on Ubuntu Linux 10.04

    Upgrade php5-xsl for Ubuntu 10.04 LTS

    Use `apt-get upgrade` to upgrade php5-xsl to the latest version

  • php5 on Ubuntu Linux 10.04

    Upgrade php5 for Ubuntu 10.04 LTS

    Use `apt-get upgrade` to upgrade php5 to the latest version

  • libapache2-mod-php5 on Ubuntu Linux 10.04

    Upgrade libapache2-mod-php5 for Ubuntu 10.04 LTS

    Use `apt-get upgrade` to upgrade libapache2-mod-php5 to the latest version

  • php5-cli on Ubuntu Linux 10.10

    Upgrade php5-cli for Ubuntu 10.10

    Use `apt-get upgrade` to upgrade php5-cli to the latest version

  • php5-cgi on Ubuntu Linux 10.10

    Upgrade php5-cgi for Ubuntu 10.10

    Use `apt-get upgrade` to upgrade php5-cgi to the latest version

  • php5-common on Ubuntu Linux 10.10

    Upgrade php5-common for Ubuntu 10.10

    Use `apt-get upgrade` to upgrade php5-common to the latest version

  • php5-xsl on Ubuntu Linux 10.10

    Upgrade php5-xsl for Ubuntu 10.10

    Use `apt-get upgrade` to upgrade php5-xsl to the latest version

  • php5 on Ubuntu Linux 10.10

    Upgrade php5 for Ubuntu 10.10

    Use `apt-get upgrade` to upgrade php5 to the latest version

  • libapache2-mod-php5 on Ubuntu Linux 10.10

    Upgrade libapache2-mod-php5 for Ubuntu 10.10

    Use `apt-get upgrade` to upgrade libapache2-mod-php5 to the latest version

  • php5-cli on Ubuntu Linux 11.04

    Upgrade php5-cli for Ubuntu 11.04

    Use `apt-get upgrade` to upgrade php5-cli to the latest version

  • php5-cgi on Ubuntu Linux 11.04

    Upgrade php5-cgi for Ubuntu 11.04

    Use `apt-get upgrade` to upgrade php5-cgi to the latest version

  • php5-common on Ubuntu Linux 11.04

    Upgrade php5-common for Ubuntu 11.04

    Use `apt-get upgrade` to upgrade php5-common to the latest version

  • php5-xsl on Ubuntu Linux 11.04

    Upgrade php5-xsl for Ubuntu 11.04

    Use `apt-get upgrade` to upgrade php5-xsl to the latest version

  • php5 on Ubuntu Linux 11.04

    Upgrade php5 for Ubuntu 11.04

    Use `apt-get upgrade` to upgrade php5 to the latest version

  • libapache2-mod-php5 on Ubuntu Linux 11.04

    Upgrade libapache2-mod-php5 for Ubuntu 11.04

    Use `apt-get upgrade` to upgrade libapache2-mod-php5 to the latest version

  • php5-cli on Ubuntu Linux 11.10

    Upgrade php5-cli for Ubuntu 11.10

    Use `apt-get upgrade` to upgrade php5-cli to the latest version

  • php5-cgi on Ubuntu Linux 11.10

    Upgrade php5-cgi for Ubuntu 11.10

    Use `apt-get upgrade` to upgrade php5-cgi to the latest version

  • php5-common on Ubuntu Linux 11.10

    Upgrade php5-common for Ubuntu 11.10

    Use `apt-get upgrade` to upgrade php5-common to the latest version

  • php5-xsl on Ubuntu Linux 11.10

    Upgrade php5-xsl for Ubuntu 11.10

    Use `apt-get upgrade` to upgrade php5-xsl to the latest version

  • php5 on Ubuntu Linux 11.10

    Upgrade php5 for Ubuntu 11.10

    Use `apt-get upgrade` to upgrade php5 to the latest version

  • libapache2-mod-php5 on Ubuntu Linux 11.10

    Upgrade libapache2-mod-php5 for Ubuntu 11.10

    Use `apt-get upgrade` to upgrade libapache2-mod-php5 to the latest version

  • php5-cli on Ubuntu Linux 8.04

    Upgrade php5-cli for Ubuntu 8.04 LTS

    Use `apt-get upgrade` to upgrade php5-cli to the latest version

  • php5-cgi on Ubuntu Linux 8.04

    Upgrade php5-cgi for Ubuntu 8.04 LTS

    Use `apt-get upgrade` to upgrade php5-cgi to the latest version

  • php5-common on Ubuntu Linux 8.04

    Upgrade php5-common for Ubuntu 8.04 LTS

    Use `apt-get upgrade` to upgrade php5-common to the latest version

  • php5-xsl on Ubuntu Linux 8.04

    Upgrade php5-xsl for Ubuntu 8.04 LTS

    Use `apt-get upgrade` to upgrade php5-xsl to the latest version

  • php5 on Ubuntu Linux 8.04

    Upgrade php5 for Ubuntu 8.04 LTS

    Use `apt-get upgrade` to upgrade php5 to the latest version

  • libapache2-mod-php5 on Ubuntu Linux 8.04

    Upgrade libapache2-mod-php5 for Ubuntu 8.04 LTS

    Use `apt-get upgrade` to upgrade libapache2-mod-php5 to the latest version

Related Vulnerabilities