Metasploit: System Requirements & Documentation

Printer Friendly Version

Officially Supported Systems

Minimum Hardware

  • 2 GHz+ processor
  • 2 GB RAM available (4 GB recommended)
  • 1 GB available disk space (50 GB recommended)
  • 10/100 Mbps network interface card

Browsers

  • Mozilla Firefox 18.0+
  • Microsoft Internet Explorer 9 and 10
  • Google Chrome 10+
  • Iceweasel 18+

Operating Systems

  • Vista, 7, 8, Server 2003, Server 2008 and Server 2012 (64 bit recommended)
  • Red Hat Enterprise Linux 5.x, 6.x - x86 and x86_64
  • Ubuntu Linux 10.04, 12.04, 14.04 - x86 and x86_64
  • Kali Linux 1.0 (Metasploit pre-installed; supported on i386 and AMD64 only)
Product Documentation

Free Penetration Testing Download

Safely simulate attacks on your network to uncover security issues with Metasploit

Start Pen Testing Today

Whitepaper - What is Penetration Testing?

Learn more about penetration testing

 Download Now

Request a Metasploit Demo

Let us walk you through Metasploit

Request A Demo

Free Metasploit Download

Reduce the risk of a data breach with our penetration testing solution

 Free Download