Mobilisafe: System Requirements

Printer Friendly Version

Architecture, Deployment, Integration, and System Requirements

For Exchange On-Premise Installations

Supported Browsers

  • Internet Explorer 8, 9
  • Chrome (latest stable version)
  • Safari 6

Software Requirements

  • Windows PowerShell 2.0
  • Microsoft .NET Framework 3.0
  • Exchange Management Server 2007 Tools (for Exchange 2007 installations)

Supported Operating Systems

  • Microsoft Exchange Server 2007 or 2010

For Office 365 Installations

Supported Browsers

  • Internet Explorer 8, 9
  • Chrome (latest stable version)
  • Safari 6

Supported Office 365 Plans

  • Enterprise E1, E2, E3, E4 and E5 versions & Mid Sized Business Version

Free Mobile Risk Management Demo

Perform a mobile risk assessment of all devices on your network with Mobilisafe

Eliminate Mobile Risks Today

Free Webcast Download

Understanding Your Mobile Vulnerabilities

Watch Now

Try Mobilisafe Today

Take a self-guided tour of our mobile security solution

Start Demo

Case Study Download

See why WildTangent switched to our mobile security product

Download Now