Rapid7 Vulnerability & Exploit Database

Webmin password_change.cgi Backdoor

Back to Search

Webmin password_change.cgi Backdoor

Disclosed
08/10/2019
Created
08/23/2019

Description

This module exploits a backdoor in Webmin versions 1.890 through 1.920. Only the SourceForge downloads were backdoored, but they are listed as official downloads on the project's site. Unknown attacker(s) inserted Perl qx statements into the build server's source code on two separate occasions: once in April 2018, introducing the backdoor in the 1.890 release, and in July 2018, reintroducing the backdoor in releases 1.900 through 1.920. Only version 1.890 is exploitable in the default install. Later affected versions require the expired password changing feature to be enabled.

Author(s)

  • AkkuS
  • wvu <wvu@metasploit.com>

Platform

Linux,Unix

Architectures

cmd, x86, x64

Development

References

Module Options

To display the available options, load the module within the Metasploit console and run the commands 'show options' or 'show advanced':

msf > use exploit/unix/webapp/webmin_backdoor
msf exploit(webmin_backdoor) > show targets
    ...targets...
msf exploit(webmin_backdoor) > set TARGET < target-id >
msf exploit(webmin_backdoor) > show options
    ...show and set options...
msf exploit(webmin_backdoor) > exploit

Time is precious, so I don’t want to do something manually that I can automate. Leveraging the Metasploit Framework when automating any task keeps us from having to re-create the wheel as we can use the existing libraries and focus our efforts where it matters.

– Jim O’Gorman | President, Offensive Security

;