Vulnerability & Exploit Database

Displaying entries 1 - 10 of 27 in total

Results for: CVE-2010-3081 Back to search

ELSA-2013-1645 Important: Oracle Linux Kernel update Vulnerability

  • Severity: 10
  • Published: May 24, 2012

Integer signedness error in the CIFSFindNext function in fs/cifs/cifssmb.c in the Linux kernel before 3.1 allows remote CIFS servers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a large length value in a response to a read request for a directory.

USN-1119-1: Linux kernel (OMAP4) vulnerabilities Vulnerability

  • Severity: 8
  • Published: November 26, 2010

The sctp_auth_asoc_get_hmac function in net/sctp/auth.c in the Linux kernel before 2.6.36 does not properly validate the hmac_ids array of an SCTP peer, which allows remote attackers to cause a denial of service (memory corruption and panic) via a crafted value in the last element of this array.

RHSA-2010:0842: kernel security and bug fix update Vulnerability

  • Severity: 8
  • Published: November 26, 2010

The kernel packages contain the Linux kernel, the core of any Linuxoperating system.This update fixes the following security issues:Red Hat would like to thank Kees Cook for reporting CVE-2010-2962 andCVE-2010-2803; Ben Hawkes for reporting CVE-2010-3081 and CVE-2010-3301;Dan Rosenberg for reporting CVE-2010-3442, CVE-2010-3705, CVE-2010...

VMSA-2011-0003: vCenter Server and ESX, Oracle (Sun) JRE is (CVE-2010-3081) Vulnerability

  • Severity: 7
  • Published: September 24, 2010

The compat_alloc_user_space functions in include/asm/compat.h files in the Linux kernel before 2.6.36-rc4-git2 on 64-bit platforms do not properly allocate the userspace memory required for the 32-bit compatibility layer, which allows local users to gain privileges by leveraging the ability of the compat_mc_getsockopt function (aka the M...

VMSA-2010-0017: Service Console OS update (CVE-2010-3081) Vulnerability

  • Severity: 7
  • Published: September 24, 2010

The compat_alloc_user_space functions in include/asm/compat.h files in the Linux kernel before 2.6.36-rc4-git2 on 64-bit platforms do not properly allocate the userspace memory required for the 32-bit compatibility layer, which allows local users to gain privileges by leveraging the ability of the compat_mc_getsockopt function (aka the M...

SUSE Linux Security Advisory: SUSE-SA:2010:050 Vulnerability

  • Severity: 7
  • Published: September 24, 2010

The compat_alloc_user_space functions in include/asm/compat.h files in the Linux kernel before 2.6.36-rc4-git2 on 64-bit platforms do not properly allocate the userspace memory required for the 32-bit compatibility layer, which allows local users to gain privileges by leveraging the ability of the compat_mc_getsockopt function (aka the M...

SUSE Linux Security Vulnerability: CVE-2010-3081 Vulnerability

  • Severity: 7
  • Published: September 24, 2010

The compat_alloc_user_space functions in include/asm/compat.h files in the Linux kernel before 2.6.36-rc4-git2 on 64-bit platforms do not properly allocate the userspace memory required for the 32-bit compatibility layer, which allows local users to gain privileges by leveraging the ability of the compat_mc_getsockopt function (aka the M...

RHSA-2010:0758: kernel-rt security and bug fix update Vulnerability

  • Severity: 7
  • Published: September 24, 2010

Updated kernel-rt packages that fix two security issues and three bugs are now available for Red Hat Enterprise MRG 1.2. The Red Hat Security Response Team has rated this update as having important security impact. Common Vulnerability Scoring System (CVSS) base scores, which give detailed severity ratings, are available for each vulner...

RHSA-2010:0719: kernel security update Vulnerability

  • Severity: 7
  • Published: September 24, 2010

The kernel packages contain the Linux kernel, the core of any Linuxoperating system.This update fixes the following security issue:Red Hat would like to thank Ben Hawkes for reporting this issue.Refer to Knowledgebase article DOC-40265 for further details:https://access.redhat.com/kb/docs/DOC-40265Users should upgrade to these updated pa...

RHSA-2010:0718: kernel security update Vulnerability

  • Severity: 7
  • Published: September 24, 2010

The kernel packages contain the Linux kernel, the core of any Linuxoperating system.This update fixes the following security issue:Red Hat would like to thank Ben Hawkes for reporting this issue.Refer to Knowledgebase article DOC-40265 for further details:https://access.redhat.com/kb/docs/DOC-40265Users should upgrade to these updated pa...