Vulnerability & Exploit Database

Displaying all 4 entries

Results for: CVE-2017-17805 Back to search

SUSE: CVE-2017-17805: SUSE Linux Security Advisory Vulnerability

  • Severity: 7
  • Published: December 20, 2017

The Salsa20 encryption algorithm in the Linux kernel before 4.14.8 does not correctly handle zero-length inputs, allowing a local attacker able to use the AF_ALG-based skcipher interface (CONFIG_CRYPTO_USER_API_SKCIPHER) to cause a denial of service (uninitialized-memory free and kernel crash) or have unspecified other impact by executin...

Huawei EulerOS: CVE-2017-17805: kernel security update Vulnerability

  • Severity: 7
  • Published: December 20, 2017

The Salsa20 encryption algorithm in the Linux kernel before 4.14.8 does not correctly handle zero-length inputs, allowing a local attacker able to use the AF_ALG-based skcipher interface (CONFIG_CRYPTO_USER_API_SKCIPHER) to cause a denial of service (uninitialized-memory free and kernel crash) or have unspecified other impact by executin...

Huawei EulerOS: CVE-2017-17805: kernel security update Vulnerability

  • Severity: 7
  • Published: December 20, 2017

The Salsa20 encryption algorithm in the Linux kernel before 4.14.8 does not correctly handle zero-length inputs, allowing a local attacker able to use the AF_ALG-based skcipher interface (CONFIG_CRYPTO_USER_API_SKCIPHER) to cause a denial of service (uninitialized-memory free and kernel crash) or have unspecified other impact by executin...

Debian: CVE-2017-17805: linux -- security update Vulnerability

  • Severity: 7
  • Published: December 20, 2017

The Salsa20 encryption algorithm in the Linux kernel before 4.14.8 does not correctly handle zero-length inputs, allowing a local attacker able to use the AF_ALG-based skcipher interface (CONFIG_CRYPTO_USER_API_SKCIPHER) to cause a denial of service (uninitialized-memory free and kernel crash) or have unspecified other impact by executin...