Vulnerability & Exploit Database

Displaying all 7 entries

Results for: CVE-2018-6574 Back to search

SUSE: CVE-2018-6574: SUSE Linux Security Advisory Vulnerability

  • Severity: 5
  • Published: February 07, 2018

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.

Oracle Solaris 11: CVE-2018-6574 (11.4 GA) Vulnerability

  • Severity: 5
  • Published: February 07, 2018

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.

Gentoo Linux: CVE-2018-6574: Go: User-assisted execution of arbitrary code Vulnerability

  • Severity: 5
  • Published: February 07, 2018

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.

Debian: CVE-2018-6574: golang-1.8 -- security update Vulnerability

  • Severity: 5
  • Published: February 07, 2018

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.

Amazon Linux AMI: CVE-2018-6574: Security patch for golang (ALAS-2018-975) Vulnerability

  • Severity: 5
  • Published: February 07, 2018

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.

Alpine Linux: CVE-2018-6574: go arbitrary code execution during go get Vulnerability

  • Severity: 5
  • Published: February 07, 2018

Go before 1.8.7, Go 1.9.x before 1.9.4, and Go 1.10 pre-releases before Go 1.10rc2 allow "go get" remote command execution during source code build, by leveraging the gcc or clang plugin feature, because -fplugin= and -plugin= arguments were not blocked.