Vulnerability & Exploit Database

Displaying entries 1 - 10 of 13 in total

Results for: CVE-2018-8822 Back to search

Alpine Linux: CVE-2018-9264: wireshark Multiple vulnerabilities Vulnerability

  • Severity: 5
  • Published: April 04, 2018

In Wireshark 2.4.0 to 2.4.5 and 2.2.0 to 2.2.13, the ADB dissector could crash with a heap-based buffer overflow. This was addressed in epan/dissectors/packet-adb.c by checking for a length inconsistency.

Alpine Linux: CVE-2018-9261: wireshark Multiple vulnerabilities Vulnerability

  • Severity: 5
  • Published: April 04, 2018

In Wireshark 2.4.0 to 2.4.5 and 2.2.0 to 2.2.13, the NBAP dissector could crash with a large loop that ends with a heap-based buffer overflow. This was addressed in epan/dissectors/packet-nbap.c by prohibiting the self-linking of DCH-IDs.

Alpine Linux: CVE-2018-9256: wireshark Multiple vulnerabilities Vulnerability

  • Severity: 5
  • Published: April 04, 2018

In Wireshark 2.4.0 to 2.4.5 and 2.2.0 to 2.2.13, the LWAPP dissector could crash. This was addressed in epan/dissectors/packet-lwapp.c by limiting the encapsulation levels to restrict the recursion depth.