Rapid7 Vulnerability & Exploit Database

AIX 5.3.0 - cmsd_advisory : AIX_rpccmsd_remote_buffer_overflow_vulnerability (IZ62672)

Back to Search

AIX 5.3.0 - cmsd_advisory : AIX_rpccmsd_remote_buffer_overflow_vulnerability (IZ62672)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
10/10/2009
Created
07/25/2018
Added
10/02/2014
Modified
10/02/2014

Description

There is a buffer overflow vulnerability in the calendar daemon library libcsa.a. A remote attacker can exploit this vulnerability when the rpc.cmsd calendar daemon is enabled in /etc/inetd.conf. The successful exploitation of this vulnerability allows a remote attacker to execute arbitrary code as the root user. The following libraries and executables are vulnerable: /usr/dt/bin/rpc.cmsd /usr/dt/lib/libcsa.a

Solution(s)

  • aix-5.3.0-aix_rpccmsd_remote_buffer_overflow_vulnerability_cmsd_advisory

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;