Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2021-3426: Moderate: python3 security update (Multiple Advisories)

Back to Search

Alma Linux: CVE-2021-3426: Moderate: python3 security update (Multiple Advisories)

Severity
3
CVSS
(AV:A/AC:L/Au:S/C:P/I:N/A:N)
Published
05/20/2021
Created
05/05/2022
Added
05/04/2022
Modified
05/20/2022

Description

There's a flaw in Python 3's pydoc. A local or adjacent attacker who discovers or is able to convince another local or adjacent user to start a pydoc server could access the server and use it to disclose sensitive information belonging to the other user that they would not normally be able to access. The highest risk of this flaw is to data confidentiality. This flaw affects Python versions before 3.8.9, Python versions before 3.9.3 and Python versions before 3.10.0a7.

Solution(s)

  • alma-upgrade-platform-python
  • alma-upgrade-platform-python-debug
  • alma-upgrade-platform-python-devel
  • alma-upgrade-python3-idle
  • alma-upgrade-python3-test
  • alma-upgrade-python3-tkinter
  • alma-upgrade-python38-Cython
  • alma-upgrade-python38-PyMySQL
  • alma-upgrade-python38-asn1crypto
  • alma-upgrade-python38-atomicwrites
  • alma-upgrade-python38-attrs
  • alma-upgrade-python38-babel
  • alma-upgrade-python38-cffi
  • alma-upgrade-python38-chardet
  • alma-upgrade-python38-cryptography
  • alma-upgrade-python38-idna
  • alma-upgrade-python38-jinja2
  • alma-upgrade-python38-markupsafe
  • alma-upgrade-python38-mod_wsgi
  • alma-upgrade-python38-more-itertools
  • alma-upgrade-python38-numpy
  • alma-upgrade-python38-numpy-doc
  • alma-upgrade-python38-numpy-f2py
  • alma-upgrade-python38-packaging
  • alma-upgrade-python38-pluggy
  • alma-upgrade-python38-ply
  • alma-upgrade-python38-psutil
  • alma-upgrade-python38-psycopg2
  • alma-upgrade-python38-psycopg2-doc
  • alma-upgrade-python38-psycopg2-tests
  • alma-upgrade-python38-py
  • alma-upgrade-python38-pycparser
  • alma-upgrade-python38-pyparsing
  • alma-upgrade-python38-pysocks
  • alma-upgrade-python38-pytest
  • alma-upgrade-python38-pytz
  • alma-upgrade-python38-pyyaml
  • alma-upgrade-python38-requests
  • alma-upgrade-python38-scipy
  • alma-upgrade-python38-setuptools
  • alma-upgrade-python38-setuptools-wheel
  • alma-upgrade-python38-six
  • alma-upgrade-python38-urllib3
  • alma-upgrade-python38-wcwidth
  • alma-upgrade-python38-wheel
  • alma-upgrade-python38-wheel-wheel
  • alma-upgrade-python39-Cython
  • alma-upgrade-python39-PyMySQL
  • alma-upgrade-python39-attrs
  • alma-upgrade-python39-cffi
  • alma-upgrade-python39-chardet
  • alma-upgrade-python39-cryptography
  • alma-upgrade-python39-idna
  • alma-upgrade-python39-iniconfig
  • alma-upgrade-python39-mod_wsgi
  • alma-upgrade-python39-more-itertools
  • alma-upgrade-python39-numpy
  • alma-upgrade-python39-numpy-doc
  • alma-upgrade-python39-numpy-f2py
  • alma-upgrade-python39-packaging
  • alma-upgrade-python39-pluggy
  • alma-upgrade-python39-ply
  • alma-upgrade-python39-psutil
  • alma-upgrade-python39-psycopg2
  • alma-upgrade-python39-psycopg2-doc
  • alma-upgrade-python39-psycopg2-tests
  • alma-upgrade-python39-py
  • alma-upgrade-python39-pycparser
  • alma-upgrade-python39-pyparsing
  • alma-upgrade-python39-pysocks
  • alma-upgrade-python39-pytest
  • alma-upgrade-python39-pyyaml
  • alma-upgrade-python39-requests
  • alma-upgrade-python39-scipy
  • alma-upgrade-python39-setuptools
  • alma-upgrade-python39-setuptools-wheel
  • alma-upgrade-python39-six
  • alma-upgrade-python39-toml
  • alma-upgrade-python39-urllib3
  • alma-upgrade-python39-wcwidth
  • alma-upgrade-python39-wheel
  • alma-upgrade-python39-wheel-wheel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;