Rapid7 Vulnerability & Exploit Database

Alma Linux: CVE-2022-219862: Important: .NET 5.0 security and bugfix update (ALSA-2022-0495)

Back to Search

Alma Linux: CVE-2022-219862: Important: .NET 5.0 security and bugfix update (ALSA-2022-0495)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
03/19/1975
Created
05/05/2022
Added
05/04/2022
Modified
05/20/2022

Description

A vulnerability was found in dotnet’s ASP.NET Core Krestel when pooling HTTP/2 and HTTP/3 headers. This flaw allows a remote, unauthenticated attacker to cause a denial of service.

Solution(s)

  • alma-upgrade-aspnetcore-runtime-5.0
  • alma-upgrade-aspnetcore-targeting-pack-5.0
  • alma-upgrade-dotnet-apphost-pack-5.0
  • alma-upgrade-dotnet-hostfxr-5.0
  • alma-upgrade-dotnet-runtime-5.0
  • alma-upgrade-dotnet-sdk-5.0
  • alma-upgrade-dotnet-sdk-5.0-source-built-artifacts
  • alma-upgrade-dotnet-targeting-pack-5.0
  • alma-upgrade-dotnet-templates-5.0

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;