Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-2688: Multiple vulnerabilities in php < 5.3.15 may allow remote code execution

Back to Search

Alpine Linux: CVE-2012-2688: Multiple vulnerabilities in php < 5.3.15 may allow remote code execution

Severity
10
CVSS
(AV:N/AC:L/Au:N/C:C/I:C/A:C)
Published
07/20/2012
Created
07/25/2018
Added
08/30/2017
Modified
01/02/2018

Description

Unspecified vulnerability in the _php_stream_scandir function in the stream implementation in PHP before 5.3.15 and 5.4.x before 5.4.5 has unknown impact and remote attack vectors, related to an "overflow."

Solution(s)

  • alpine-linux-upgrade-php

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;