Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-3488: Vulnerability in pgsql < 9.1.5 may allow information disclosure

Back to Search

Alpine Linux: CVE-2012-3488: Vulnerability in pgsql < 9.1.5 may allow information disclosure

Severity
5
CVSS
(AV:N/AC:M/Au:S/C:P/I:P/A:N)
Published
10/03/2012
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

The libxslt support in contrib/xml2 in PostgreSQL 8.3 before 8.3.20, 8.4 before 8.4.13, 9.0 before 9.0.9, and 9.1 before 9.1.5 does not properly restrict access to files and URLs, which allows remote authenticated users to modify data, obtain sensitive information, or trigger outbound traffic to arbitrary external hosts by leveraging (1) stylesheet commands that are permitted by the libxslt security options or (2) an xslt_process feature, related to an XML External Entity (aka XXE) issue.

Solution(s)

  • alpine-linux-upgrade-postgresql

References

  • alpine-linux-upgrade-postgresql

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;