Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2012-5195: Vulnerability in perl < 5.12.5, 5.14.3 allows remote code execution

Back to Search

Alpine Linux: CVE-2012-5195: Vulnerability in perl < 5.12.5, 5.14.3 allows remote code execution

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
12/17/2012
Created
07/25/2018
Added
08/30/2017
Modified
11/03/2017

Description

Heap-based buffer overflow in the Perl_repeatcpy function in util.c in Perl 5.12.x before 5.12.5, 5.14.x before 5.14.3, and 5.15.x before 15.15.5 allows context-dependent attackers to cause a denial of service (memory consumption and crash) or possibly execute arbitrary code via the 'x' string repeat operator.

Solution(s)

  • alpine-linux-upgrade-perl

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;