Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2013-0156: Vulnerability in rails < 2.3.15 allows remote denial of service

Back to Search

Alpine Linux: CVE-2013-0156: Vulnerability in rails < 2.3.15 allows remote denial of service

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
01/13/2013
Created
07/25/2018
Added
08/30/2017
Modified
11/03/2017

Description

active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before 3.0.19, 3.1.x before 3.1.10, and 3.2.x before 3.2.11 does not properly restrict casts of string values, which allows remote attackers to conduct object-injection attacks and execute arbitrary code, or cause a denial of service (memory and CPU consumption) involving nested XML entity references, by leveraging Action Pack support for (1) YAML type conversion or (2) Symbol type conversion.

Solution(s)

  • alpine-linux-upgrade-ruby-activesupport

References

  • alpine-linux-upgrade-ruby-activesupport

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;