Vulnerability & Exploit Database

Back to search

Alpine Linux: CVE-2013-0255: Vulnerabilty in postgresql < 9.2.3,9.1.8,9.0.12 allows remote denial of service

Severity CVSS Published Added Modified
7 (AV:N/AC:L/Au:S/C:N/I:N/A:C) February 12, 2013 August 30, 2017 September 22, 2017

Description

PostgreSQL 9.2.x before 9.2.3, 9.1.x before 9.1.8, 9.0.x before 9.0.12, 8.4.x before 8.4.16, and 8.3.x before 8.3.23 does not properly declare the enum_recv function in backend/utils/adt/enum.c, which causes it to be invoked with incorrect arguments and allows remote authenticated users to cause a denial of service (server crash) or read sensitive process memory via a crafted SQL command, which triggers an array index error and an out-of-bounds read.

Scan For This Vulnerability

Use our top-rated tool to discover, prioritize, and remediate your vulnerabilities

 Free InsightVM Trial

References

Solution

alpine-linux-upgrade-postgresql

Related Vulnerabilities