Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2013-0276: Vulnerability in ruby ActiveRecord < 3.2.12,2.3.17 allows authentication bypass

Back to Search

Alpine Linux: CVE-2013-0276: Vulnerability in ruby ActiveRecord < 3.2.12,2.3.17 allows authentication bypass

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
02/12/2013
Created
07/25/2018
Added
08/30/2017
Modified
09/22/2017

Description

ActiveRecord in Ruby on Rails before 2.3.17, 3.1.x before 3.1.11, and 3.2.x before 3.2.12 allows remote attackers to bypass the attr_protected protection mechanism and modify protected model attributes via a crafted request.

Solution(s)

  • alpine-linux-upgrade-ruby-activerecord

References

  • alpine-linux-upgrade-ruby-activerecord

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;