Rapid7 Vulnerability & Exploit Database

Alpine Linux: CVE-2023-5869: Integer Overflow or Wraparound

Free InsightVM Trial No Credit Card Necessary
2024 Attack Intel Report Latest research by Rapid7 Labs
Back to Search

Alpine Linux: CVE-2023-5869: Integer Overflow or Wraparound

Severity
9
CVSS
(AV:N/AC:L/Au:S/C:C/I:C/A:C)
Published
12/10/2023
Created
04/09/2024
Added
03/26/2024
Modified
04/09/2024

Description

A flaw was found in PostgreSQL that allows authenticated database users to execute arbitrary code through missing overflow checks during SQL array value modification. This issue exists due to an integer overflow during array modification where a remote user can trigger the overflow by providing specially crafted data. This enables the execution of arbitrary code on the target system, allowing users to write arbitrary bytes to memory and extensively read the server's memory.

Solution(s)

  • alpine-linux-upgrade-postgresql14

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;