Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2020-12403: Security patch for nss, nss-softokn, nss-util, nspr (ALAS-2020-1559)

Back to Search

Amazon Linux AMI 2: CVE-2020-12403: Security patch for nss, nss-softokn, nss-util, nspr (ALAS-2020-1559)

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
11/12/2020
Created
11/13/2020
Added
11/12/2020
Modified
06/11/2021

Description

A flaw was found in the way CHACHA20-POLY1305 was implemented in NSS in versions before 3.55. When using multi-part Chacha20, it could cause out-of-bounds reads. This issue was fixed by explicitly disabling multi-part ChaCha20 (which was not functioning correctly) and strictly enforcing tag length. The highest threat from this vulnerability is to confidentiality and system availability.

Solution(s)

  • amazon-linux-ami-2-upgrade-nspr
  • amazon-linux-ami-2-upgrade-nspr-debuginfo
  • amazon-linux-ami-2-upgrade-nspr-devel
  • amazon-linux-ami-2-upgrade-nss
  • amazon-linux-ami-2-upgrade-nss-debuginfo
  • amazon-linux-ami-2-upgrade-nss-devel
  • amazon-linux-ami-2-upgrade-nss-pkcs11-devel
  • amazon-linux-ami-2-upgrade-nss-softokn
  • amazon-linux-ami-2-upgrade-nss-softokn-debuginfo
  • amazon-linux-ami-2-upgrade-nss-softokn-devel
  • amazon-linux-ami-2-upgrade-nss-softokn-freebl
  • amazon-linux-ami-2-upgrade-nss-softokn-freebl-devel
  • amazon-linux-ami-2-upgrade-nss-sysinit
  • amazon-linux-ami-2-upgrade-nss-tools
  • amazon-linux-ami-2-upgrade-nss-util
  • amazon-linux-ami-2-upgrade-nss-util-debuginfo
  • amazon-linux-ami-2-upgrade-nss-util-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;