Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2022-34266: Security patch for libtiff (ALAS-2022-1814)

Back to Search

Amazon Linux AMI 2: CVE-2022-34266: Security patch for libtiff (ALAS-2022-1814)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
07/19/2022
Created
09/30/2022
Added
09/30/2022
Modified
09/30/2022

Description

The libtiff-4.0.3-35.amzn2.0.1 package for LibTIFF on Amazon Linux 2 allows attackers to cause a denial of service (application crash), a different vulnerability than CVE-2022-0562. When processing a malicious TIFF file, an invalid range may be passed as an argument to the memset() function within TIFFFetchStripThing() in tif_dirread.c. This will cause TIFFFetchStripThing() to segfault after use of an uninitialized resource.

Solution(s)

  • amazon-linux-ami-2-upgrade-libtiff
  • amazon-linux-ami-2-upgrade-libtiff-debuginfo
  • amazon-linux-ami-2-upgrade-libtiff-devel
  • amazon-linux-ami-2-upgrade-libtiff-static
  • amazon-linux-ami-2-upgrade-libtiff-tools

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;