Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI 2: CVE-2023-6185: Security patch for libreoffice (ALASLIBREOFFICE-2024-003)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

Amazon Linux AMI 2: CVE-2023-6185: Security patch for libreoffice (ALASLIBREOFFICE-2024-003)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
12/11/2023
Created
05/01/2024
Added
05/01/2024
Modified
05/01/2024

Description

Improper Input Validation vulnerability in GStreamer integration of The Document Foundation LibreOffice allows an attacker to execute arbitrary GStreamer plugins. In affected versions the filename of the embedded video is not sufficiently escaped when passed to GStreamer enabling an attacker to run arbitrary gstreamer plugins depending on what plugins are installed on the target system.

Solution(s)

  • amazon-linux-ami-2-upgrade-autocorr-af
  • amazon-linux-ami-2-upgrade-autocorr-bg
  • amazon-linux-ami-2-upgrade-autocorr-ca
  • amazon-linux-ami-2-upgrade-autocorr-cs
  • amazon-linux-ami-2-upgrade-autocorr-da
  • amazon-linux-ami-2-upgrade-autocorr-de
  • amazon-linux-ami-2-upgrade-autocorr-en
  • amazon-linux-ami-2-upgrade-autocorr-es
  • amazon-linux-ami-2-upgrade-autocorr-fa
  • amazon-linux-ami-2-upgrade-autocorr-fi
  • amazon-linux-ami-2-upgrade-autocorr-fr
  • amazon-linux-ami-2-upgrade-autocorr-ga
  • amazon-linux-ami-2-upgrade-autocorr-hr
  • amazon-linux-ami-2-upgrade-autocorr-hu
  • amazon-linux-ami-2-upgrade-autocorr-is
  • amazon-linux-ami-2-upgrade-autocorr-it
  • amazon-linux-ami-2-upgrade-autocorr-ja
  • amazon-linux-ami-2-upgrade-autocorr-ko
  • amazon-linux-ami-2-upgrade-autocorr-lb
  • amazon-linux-ami-2-upgrade-autocorr-lt
  • amazon-linux-ami-2-upgrade-autocorr-mn
  • amazon-linux-ami-2-upgrade-autocorr-nl
  • amazon-linux-ami-2-upgrade-autocorr-pl
  • amazon-linux-ami-2-upgrade-autocorr-pt
  • amazon-linux-ami-2-upgrade-autocorr-ro
  • amazon-linux-ami-2-upgrade-autocorr-ru
  • amazon-linux-ami-2-upgrade-autocorr-sk
  • amazon-linux-ami-2-upgrade-autocorr-sl
  • amazon-linux-ami-2-upgrade-autocorr-sr
  • amazon-linux-ami-2-upgrade-autocorr-sv
  • amazon-linux-ami-2-upgrade-autocorr-tr
  • amazon-linux-ami-2-upgrade-autocorr-vi
  • amazon-linux-ami-2-upgrade-autocorr-zh
  • amazon-linux-ami-2-upgrade-libreoffice
  • amazon-linux-ami-2-upgrade-libreoffice-base
  • amazon-linux-ami-2-upgrade-libreoffice-bsh
  • amazon-linux-ami-2-upgrade-libreoffice-calc
  • amazon-linux-ami-2-upgrade-libreoffice-core
  • amazon-linux-ami-2-upgrade-libreoffice-data
  • amazon-linux-ami-2-upgrade-libreoffice-debuginfo
  • amazon-linux-ami-2-upgrade-libreoffice-draw
  • amazon-linux-ami-2-upgrade-libreoffice-emailmerge
  • amazon-linux-ami-2-upgrade-libreoffice-filters
  • amazon-linux-ami-2-upgrade-libreoffice-gdb-debug-support
  • amazon-linux-ami-2-upgrade-libreoffice-glade
  • amazon-linux-ami-2-upgrade-libreoffice-graphicfilter
  • amazon-linux-ami-2-upgrade-libreoffice-gtk2
  • amazon-linux-ami-2-upgrade-libreoffice-gtk3
  • amazon-linux-ami-2-upgrade-libreoffice-help-ar
  • amazon-linux-ami-2-upgrade-libreoffice-help-bg
  • amazon-linux-ami-2-upgrade-libreoffice-help-bn
  • amazon-linux-ami-2-upgrade-libreoffice-help-ca
  • amazon-linux-ami-2-upgrade-libreoffice-help-cs
  • amazon-linux-ami-2-upgrade-libreoffice-help-da
  • amazon-linux-ami-2-upgrade-libreoffice-help-de
  • amazon-linux-ami-2-upgrade-libreoffice-help-dz
  • amazon-linux-ami-2-upgrade-libreoffice-help-el
  • amazon-linux-ami-2-upgrade-libreoffice-help-es
  • amazon-linux-ami-2-upgrade-libreoffice-help-et
  • amazon-linux-ami-2-upgrade-libreoffice-help-eu
  • amazon-linux-ami-2-upgrade-libreoffice-help-fr
  • amazon-linux-ami-2-upgrade-libreoffice-help-gl
  • amazon-linux-ami-2-upgrade-libreoffice-help-gu
  • amazon-linux-ami-2-upgrade-libreoffice-help-hi
  • amazon-linux-ami-2-upgrade-libreoffice-help-hr
  • amazon-linux-ami-2-upgrade-libreoffice-help-hu
  • amazon-linux-ami-2-upgrade-libreoffice-help-id
  • amazon-linux-ami-2-upgrade-libreoffice-help-it
  • amazon-linux-ami-2-upgrade-libreoffice-help-ja
  • amazon-linux-ami-2-upgrade-libreoffice-help-ko
  • amazon-linux-ami-2-upgrade-libreoffice-help-lt
  • amazon-linux-ami-2-upgrade-libreoffice-help-lv
  • amazon-linux-ami-2-upgrade-libreoffice-help-nb
  • amazon-linux-ami-2-upgrade-libreoffice-help-nl
  • amazon-linux-ami-2-upgrade-libreoffice-help-nn
  • amazon-linux-ami-2-upgrade-libreoffice-help-pl
  • amazon-linux-ami-2-upgrade-libreoffice-help-pt-br
  • amazon-linux-ami-2-upgrade-libreoffice-help-pt-pt
  • amazon-linux-ami-2-upgrade-libreoffice-help-ro
  • amazon-linux-ami-2-upgrade-libreoffice-help-ru
  • amazon-linux-ami-2-upgrade-libreoffice-help-si
  • amazon-linux-ami-2-upgrade-libreoffice-help-sk
  • amazon-linux-ami-2-upgrade-libreoffice-help-sl
  • amazon-linux-ami-2-upgrade-libreoffice-help-sv
  • amazon-linux-ami-2-upgrade-libreoffice-help-ta
  • amazon-linux-ami-2-upgrade-libreoffice-help-tr
  • amazon-linux-ami-2-upgrade-libreoffice-help-uk
  • amazon-linux-ami-2-upgrade-libreoffice-help-zh-hans
  • amazon-linux-ami-2-upgrade-libreoffice-help-zh-hant
  • amazon-linux-ami-2-upgrade-libreoffice-impress
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-af
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ar
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-as
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-bg
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-bn
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-br
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ca
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-cs
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-cy
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-da
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-de
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-dz
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-el
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-en
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-es
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-et
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-eu
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-fa
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-fr
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ga
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-gl
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-gu
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-hi
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-hr
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-hu
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-id
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-it
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ja
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-kk
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-kn
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ko
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-lt
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-lv
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-mai
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ml
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-mr
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-nb
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-nl
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-nn
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-nr
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-nso
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-or
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-pa
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-pl
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-pt-br
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-pt-pt
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ro
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ru
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-si
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-sk
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-sl
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-sr
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ss
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-st
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-sv
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ta
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-te
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-th
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-tn
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-tr
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ts
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-uk
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-ve
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-xh
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-zh-hans
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-zh-hant
  • amazon-linux-ami-2-upgrade-libreoffice-langpack-zu
  • amazon-linux-ami-2-upgrade-libreoffice-librelogo
  • amazon-linux-ami-2-upgrade-libreoffice-math
  • amazon-linux-ami-2-upgrade-libreoffice-nlpsolver
  • amazon-linux-ami-2-upgrade-libreoffice-officebean
  • amazon-linux-ami-2-upgrade-libreoffice-officebean-common
  • amazon-linux-ami-2-upgrade-libreoffice-ogltrans
  • amazon-linux-ami-2-upgrade-libreoffice-opensymbol-fonts
  • amazon-linux-ami-2-upgrade-libreoffice-pdfimport
  • amazon-linux-ami-2-upgrade-libreoffice-postgresql
  • amazon-linux-ami-2-upgrade-libreoffice-pyuno
  • amazon-linux-ami-2-upgrade-libreoffice-rhino
  • amazon-linux-ami-2-upgrade-libreoffice-sdk
  • amazon-linux-ami-2-upgrade-libreoffice-sdk-doc
  • amazon-linux-ami-2-upgrade-libreoffice-ure
  • amazon-linux-ami-2-upgrade-libreoffice-ure-common
  • amazon-linux-ami-2-upgrade-libreoffice-wiki-publisher
  • amazon-linux-ami-2-upgrade-libreoffice-writer
  • amazon-linux-ami-2-upgrade-libreoffice-x11
  • amazon-linux-ami-2-upgrade-libreoffice-xsltfilter
  • amazon-linux-ami-2-upgrade-libreofficekit
  • amazon-linux-ami-2-upgrade-libreofficekit-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;