Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: Security patch for php (ALAS-2013-205) (CVE-2013-2110)

Back to Search

Amazon Linux AMI: Security patch for php (ALAS-2013-205) (CVE-2013-2110)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
06/21/2013
Created
07/25/2018
Added
02/28/2014
Modified
07/04/2017

Description

Heap-based buffer overflow in the php_quot_print_encode function in ext/standard/quot_print.c in PHP before 5.3.26 and 5.4.x before 5.4.16 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted argument to the quoted_printable_encode function.

Solution(s)

  • amazon-linux-upgrade-php
  • amazon-linux-upgrade-php-bcmath
  • amazon-linux-upgrade-php-cli
  • amazon-linux-upgrade-php-common
  • amazon-linux-upgrade-php-dba
  • amazon-linux-upgrade-php-debuginfo
  • amazon-linux-upgrade-php-devel
  • amazon-linux-upgrade-php-embedded
  • amazon-linux-upgrade-php-enchant
  • amazon-linux-upgrade-php-fpm
  • amazon-linux-upgrade-php-gd
  • amazon-linux-upgrade-php-imap
  • amazon-linux-upgrade-php-intl
  • amazon-linux-upgrade-php-ldap
  • amazon-linux-upgrade-php-mbstring
  • amazon-linux-upgrade-php-mcrypt
  • amazon-linux-upgrade-php-mssql
  • amazon-linux-upgrade-php-mysql
  • amazon-linux-upgrade-php-mysqlnd
  • amazon-linux-upgrade-php-odbc
  • amazon-linux-upgrade-php-pdo
  • amazon-linux-upgrade-php-pgsql
  • amazon-linux-upgrade-php-process
  • amazon-linux-upgrade-php-pspell
  • amazon-linux-upgrade-php-recode
  • amazon-linux-upgrade-php-snmp
  • amazon-linux-upgrade-php-soap
  • amazon-linux-upgrade-php-tidy
  • amazon-linux-upgrade-php-xml
  • amazon-linux-upgrade-php-xmlrpc

References

  • amazon-linux-upgrade-php
  • amazon-linux-upgrade-php-bcmath
  • amazon-linux-upgrade-php-cli
  • amazon-linux-upgrade-php-common
  • amazon-linux-upgrade-php-dba
  • amazon-linux-upgrade-php-debuginfo
  • amazon-linux-upgrade-php-devel
  • amazon-linux-upgrade-php-embedded
  • amazon-linux-upgrade-php-enchant
  • amazon-linux-upgrade-php-fpm
  • amazon-linux-upgrade-php-gd
  • amazon-linux-upgrade-php-imap
  • amazon-linux-upgrade-php-intl
  • amazon-linux-upgrade-php-ldap
  • amazon-linux-upgrade-php-mbstring
  • amazon-linux-upgrade-php-mcrypt
  • amazon-linux-upgrade-php-mssql
  • amazon-linux-upgrade-php-mysql
  • amazon-linux-upgrade-php-mysqlnd
  • amazon-linux-upgrade-php-odbc
  • amazon-linux-upgrade-php-pdo
  • amazon-linux-upgrade-php-pgsql
  • amazon-linux-upgrade-php-process
  • amazon-linux-upgrade-php-pspell
  • amazon-linux-upgrade-php-recode
  • amazon-linux-upgrade-php-snmp
  • amazon-linux-upgrade-php-soap
  • amazon-linux-upgrade-php-tidy
  • amazon-linux-upgrade-php-xml
  • amazon-linux-upgrade-php-xmlrpc

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;