Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: Security patch for gc (ALAS-2013-245) (CVE-2012-2673)

Back to Search

Amazon Linux AMI: Security patch for gc (ALAS-2013-245) (CVE-2012-2673)

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
07/25/2012
Created
07/25/2018
Added
02/28/2014
Modified
07/04/2017

Description

Multiple integer overflows in the (1) GC_generic_malloc and (2) calloc funtions in malloc.c, and the (3) GC_generic_malloc_ignore_off_page function in mallocx.c in Boehm-Demers-Weiser GC (libgc) before 7.2 make it easier for context-dependent attackers to perform memory-related attacks such as buffer overflows via a large size value, which causes less memory to be allocated than expected.

Solution(s)

  • amazon-linux-upgrade-gc
  • amazon-linux-upgrade-gc-debuginfo
  • amazon-linux-upgrade-gc-devel

References

  • amazon-linux-upgrade-gc
  • amazon-linux-upgrade-gc-debuginfo
  • amazon-linux-upgrade-gc-devel

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;