Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: Security patch for lzo (ALAS-2014-373) (CVE-2014-4607)

Back to Search

Amazon Linux AMI: Security patch for lzo (ALAS-2014-373) (CVE-2014-4607)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/26/2014
Created
07/25/2018
Added
09/26/2014
Modified
07/04/2017

Description

An integer overflow flaw was found in the way the lzo library decompressed certain archives compressed with the LZO algorithm. An attacker could create a specially crafted LZO-compressed input that, when decompressed by an application using the lzo library, would cause that application to crash or, potentially, execute arbitrary code. (CVE-2014-4607 )

Solution(s)

  • amazon-linux-upgrade-lzo
  • amazon-linux-upgrade-lzo-debuginfo
  • amazon-linux-upgrade-lzo-devel
  • amazon-linux-upgrade-lzo-minilzo

References

  • amazon-linux-upgrade-lzo
  • amazon-linux-upgrade-lzo-debuginfo
  • amazon-linux-upgrade-lzo-devel
  • amazon-linux-upgrade-lzo-minilzo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;