Rapid7 Vulnerability & Exploit Database

Amazon Linux AMI: Security patch for php-ZendFramework (ALAS-2014-460) (multiple CVEs)

Back to Search

Amazon Linux AMI: Security patch for php-ZendFramework (ALAS-2014-460) (multiple CVEs)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
10/22/2014
Created
07/25/2018
Added
12/15/2014
Modified
03/05/2020

Description

SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.

Solution(s)

  • amazon-linux-upgrade-php-zendframework
  • amazon-linux-upgrade-php-zendframework-auth-adapter-ldap
  • amazon-linux-upgrade-php-zendframework-cache-backend-apc
  • amazon-linux-upgrade-php-zendframework-cache-backend-libmemcached
  • amazon-linux-upgrade-php-zendframework-cache-backend-memcached
  • amazon-linux-upgrade-php-zendframework-captcha
  • amazon-linux-upgrade-php-zendframework-db-adapter-mysqli
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo-mssql
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo-mysql
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo-pgsql
  • amazon-linux-upgrade-php-zendframework-demos
  • amazon-linux-upgrade-php-zendframework-dojo
  • amazon-linux-upgrade-php-zendframework-extras
  • amazon-linux-upgrade-php-zendframework-feed
  • amazon-linux-upgrade-php-zendframework-full
  • amazon-linux-upgrade-php-zendframework-ldap
  • amazon-linux-upgrade-php-zendframework-pdf
  • amazon-linux-upgrade-php-zendframework-search-lucene
  • amazon-linux-upgrade-php-zendframework-serializer-adapter-igbinary
  • amazon-linux-upgrade-php-zendframework-services
  • amazon-linux-upgrade-php-zendframework-soap

References

  • amazon-linux-upgrade-php-zendframework
  • amazon-linux-upgrade-php-zendframework-auth-adapter-ldap
  • amazon-linux-upgrade-php-zendframework-cache-backend-apc
  • amazon-linux-upgrade-php-zendframework-cache-backend-libmemcached
  • amazon-linux-upgrade-php-zendframework-cache-backend-memcached
  • amazon-linux-upgrade-php-zendframework-captcha
  • amazon-linux-upgrade-php-zendframework-db-adapter-mysqli
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo-mssql
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo-mysql
  • amazon-linux-upgrade-php-zendframework-db-adapter-pdo-pgsql
  • amazon-linux-upgrade-php-zendframework-demos
  • amazon-linux-upgrade-php-zendframework-dojo
  • amazon-linux-upgrade-php-zendframework-extras
  • amazon-linux-upgrade-php-zendframework-feed
  • amazon-linux-upgrade-php-zendframework-full
  • amazon-linux-upgrade-php-zendframework-ldap
  • amazon-linux-upgrade-php-zendframework-pdf
  • amazon-linux-upgrade-php-zendframework-search-lucene
  • amazon-linux-upgrade-php-zendframework-serializer-adapter-igbinary
  • amazon-linux-upgrade-php-zendframework-services
  • amazon-linux-upgrade-php-zendframework-soap

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;