Rapid7 Vulnerability & Exploit Database

OS X update for Ruby (CVE-2017-0898)

Back to Search

OS X update for Ruby (CVE-2017-0898)

Severity
6
CVSS
(AV:N/AC:L/Au:N/C:P/I:N/A:P)
Published
09/15/2017
Created
03/19/2019
Added
10/31/2018
Modified
03/18/2020

Description

Ruby before 2.4.2, 2.3.5, and 2.2.8 is vulnerable to a malicious format string which contains a precious specifier (*) with a huge minus value. Such situation can lead to a buffer overrun, resulting in a heap memory corruption or an information disclosure from the heap.

Solution(s)

  • apple-osx-security-update-2018-002-high-sierra
  • apple-osx-upgrade-10_13_6

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;