Rapid7 Vulnerability & Exploit Database

Cent OS: CVE-2008-2938: CESA-2008:0648 (tomcat)

Back to Search

Cent OS: CVE-2008-2938: CESA-2008:0648 (tomcat)

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:P/I:N/A:N)
Published
08/12/2008
Created
07/25/2018
Added
12/01/2016
Modified
07/04/2017

Description

Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking and UTF-8 are enabled, allows remote attackers to read arbitrary files via encoded directory traversal sequences in the URI, a different vulnerability than CVE-2008-2370. NOTE: versions earlier than 6.0.18 were reported affected, but the vendor advisory lists 6.0.16 as the last affected version.

Solution(s)

  • centos-upgrade-tomcat5
  • centos-upgrade-tomcat5-admin-webapps
  • centos-upgrade-tomcat5-common-lib
  • centos-upgrade-tomcat5-jasper
  • centos-upgrade-tomcat5-jasper-javadoc
  • centos-upgrade-tomcat5-jsp-2-0-api
  • centos-upgrade-tomcat5-jsp-2-0-api-javadoc
  • centos-upgrade-tomcat5-server-lib
  • centos-upgrade-tomcat5-servlet-2-4-api
  • centos-upgrade-tomcat5-servlet-2-4-api-javadoc
  • centos-upgrade-tomcat5-webapps

References

  • centos-upgrade-tomcat5
  • centos-upgrade-tomcat5-admin-webapps
  • centos-upgrade-tomcat5-common-lib
  • centos-upgrade-tomcat5-jasper
  • centos-upgrade-tomcat5-jasper-javadoc
  • centos-upgrade-tomcat5-jsp-2-0-api
  • centos-upgrade-tomcat5-jsp-2-0-api-javadoc
  • centos-upgrade-tomcat5-server-lib
  • centos-upgrade-tomcat5-servlet-2-4-api
  • centos-upgrade-tomcat5-servlet-2-4-api-javadoc
  • centos-upgrade-tomcat5-webapps

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;