Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2019-1010238: Important: pango security update (Multiple Advisories)

Back to Search

Centos Linux: CVE-2019-1010238: Important: pango security update (Multiple Advisories)

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
07/19/2019
Created
08/30/2019
Added
08/29/2019
Modified
03/03/2021

Description

Gnome Pango 1.42 and later is affected by: Buffer Overflow. The impact is: The heap based buffer overflow can be used to get code execution. The component is: function name: pango_log2vis_get_embedding_levels, assignment of nchars and the loop condition. The attack vector is: Bug can be used when application pass invalid utf-8 strings to functions like pango_itemize.

Solution(s)

  • centos-upgrade-pango
  • centos-upgrade-pango-debuginfo
  • centos-upgrade-pango-debugsource
  • centos-upgrade-pango-devel
  • centos-upgrade-pango-tests
  • centos-upgrade-pango-tests-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;