Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2019-1387: Important: git security update (Multiple Advisories)

Back to Search

Centos Linux: CVE-2019-1387: Important: git security update (Multiple Advisories)

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
12/18/2019
Created
12/24/2019
Added
12/23/2019
Modified
03/03/2021

Description

An issue was found in Git before v2.24.1, v2.23.1, v2.22.2, v2.21.1, v2.20.2, v2.19.3, v2.18.2, v2.17.3, v2.16.6, v2.15.4, and v2.14.6. Recursive clones are currently affected by a vulnerability that is caused by too-lax validation of submodule names, allowing very targeted attacks via remote code execution in recursive clones.

Solution(s)

  • centos-upgrade-emacs-git
  • centos-upgrade-emacs-git-el
  • centos-upgrade-git
  • centos-upgrade-git-all
  • centos-upgrade-git-bzr
  • centos-upgrade-git-core
  • centos-upgrade-git-core-debuginfo
  • centos-upgrade-git-core-doc
  • centos-upgrade-git-cvs
  • centos-upgrade-git-daemon
  • centos-upgrade-git-daemon-debuginfo
  • centos-upgrade-git-debuginfo
  • centos-upgrade-git-debugsource
  • centos-upgrade-git-email
  • centos-upgrade-git-gnome-keyring
  • centos-upgrade-git-gui
  • centos-upgrade-git-hg
  • centos-upgrade-git-instaweb
  • centos-upgrade-git-p4
  • centos-upgrade-git-subtree
  • centos-upgrade-git-svn
  • centos-upgrade-git-svn-debuginfo
  • centos-upgrade-gitk
  • centos-upgrade-gitweb
  • centos-upgrade-perl-git
  • centos-upgrade-perl-git-svn

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;