Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2019-20807: Moderate: vim security update (CESA-2020:4453)

Back to Search

Centos Linux: CVE-2019-20807: Moderate: vim security update (CESA-2020:4453)

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
05/28/2020
Created
11/06/2020
Added
11/05/2020
Modified
11/09/2020

Description

In Vim before 8.1.0881, users can circumvent the rvim restricted mode and execute arbitrary OS commands via scripting interfaces (e.g., Python, Ruby, or Lua).

Solution(s)

  • centos-upgrade-vim-common
  • centos-upgrade-vim-common-debuginfo
  • centos-upgrade-vim-debuginfo
  • centos-upgrade-vim-debugsource
  • centos-upgrade-vim-enhanced
  • centos-upgrade-vim-enhanced-debuginfo
  • centos-upgrade-vim-filesystem
  • centos-upgrade-vim-minimal
  • centos-upgrade-vim-minimal-debuginfo
  • centos-upgrade-vim-x11
  • centos-upgrade-vim-x11-debuginfo

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;