Rapid7 Vulnerability & Exploit Database

Centos Linux: CVE-2022-27666: Important: kpatch-patch security update (Multiple Advisories)

Back to Search

Centos Linux: CVE-2022-27666: Important: kpatch-patch security update (Multiple Advisories)

Severity
5
CVSS
(AV:L/AC:L/Au:N/C:P/I:P/A:P)
Published
03/23/2022
Created
07/16/2022
Added
06/29/2022
Modified
07/06/2022

Description

A heap buffer overflow flaw was found in IPsec ESP transformation code in net/ipv4/esp4.c and net/ipv6/esp6.c. This flaw allows a local attacker with a normal user privilege to overwrite kernel heap objects and may cause a local privilege escalation threat.

Solution(s)

  • centos-upgrade-kernel
  • centos-upgrade-kernel-rt
  • centos-upgrade-kpatch-patch-4_18_0-372_9_1
  • centos-upgrade-kpatch-patch-4_18_0-372_9_1-debuginfo
  • centos-upgrade-kpatch-patch-4_18_0-372_9_1-debugsource
  • centos-upgrade-kpatch-patch-5_14_0-70_13_1
  • centos-upgrade-kpatch-patch-5_14_0-70_13_1-debuginfo
  • centos-upgrade-kpatch-patch-5_14_0-70_13_1-debugsource

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;