Rapid7 Vulnerability & Exploit Database

CentOS Linux: CVE-2023-23946: Important: git security update (Multiple Advisories)

Free InsightVM Trial No Credit Card Necessary
Watch Demo See how it all works
Back to Search

CentOS Linux: CVE-2023-23946: Important: git security update (Multiple Advisories)

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
02/14/2023
Created
05/23/2023
Added
05/23/2023
Modified
05/25/2023

Description

Git, a revision control system, is vulnerable to path traversal prior to versions 2.39.2, 2.38.4, 2.37.6, 2.36.5, 2.35.7, 2.34.7, 2.33.7, 2.32.6, 2.31.7, and 2.30.8. By feeding a crafted input to `git apply`, a path outside the working tree can be overwritten as the user who is running `git apply`. A fix has been prepared and will appear in v2.39.2, v2.38.4, v2.37.6, v2.36.5, v2.35.7, v2.34.7, v2.33.7, v2.32.6, v2.31.7, and v2.30.8. As a workaround, use `git apply --stat` to inspect a patch before applying; avoid applying one that creates a symbolic link and then creates a file beyond the symbolic link.

Solution(s)

  • centos-upgrade-git
  • centos-upgrade-git-all
  • centos-upgrade-git-core
  • centos-upgrade-git-core-debuginfo
  • centos-upgrade-git-core-doc
  • centos-upgrade-git-credential-libsecret
  • centos-upgrade-git-credential-libsecret-debuginfo
  • centos-upgrade-git-daemon
  • centos-upgrade-git-daemon-debuginfo
  • centos-upgrade-git-debuginfo
  • centos-upgrade-git-debugsource
  • centos-upgrade-git-email
  • centos-upgrade-git-gui
  • centos-upgrade-git-instaweb
  • centos-upgrade-git-subtree
  • centos-upgrade-git-svn
  • centos-upgrade-gitk
  • centos-upgrade-gitweb
  • centos-upgrade-perl-git
  • centos-upgrade-perl-git-svn

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;