Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-10241: jetty9 -- security update

Back to Search

Debian: CVE-2019-10241: jetty9 -- security update

Severity
4
CVSS
(AV:N/AC:M/Au:N/C:N/I:P/A:N)
Published
04/22/2019
Created
05/18/2021
Added
05/17/2021
Modified
08/20/2021

Description

In Eclipse Jetty version 9.2.26 and older, 9.3.25 and older, and 9.4.15 and older, the server is vulnerable to XSS conditions if a remote client USES a specially formatted URL against the DefaultServlet or ResourceHandler that is configured for showing a Listing of directory contents.

Solution(s)

  • debian-upgrade-jetty9

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;