Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-12211: freeimage -- security update

Back to Search

Debian: CVE-2019-12211: freeimage -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:N/A:P)
Published
05/20/2019
Created
12/13/2019
Added
12/12/2019
Modified
02/10/2020

Description

When FreeImage 3.18.0 reads a tiff file, it will be handed to the Load function of the PluginTIFF.cpp file, but a memcpy occurs in which the destination address and the size of the copied data are not considered, resulting in a heap overflow.

Solution(s)

  • debian-upgrade-freeimage

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;