Rapid7 Vulnerability & Exploit Database

Debian: CVE-2019-12472: mediawiki -- security update

Back to Search

Debian: CVE-2019-12472: mediawiki -- security update

Severity
5
CVSS
(AV:N/AC:L/Au:N/C:N/I:P/A:N)
Published
06/12/2019
Created
06/13/2019
Added
06/12/2019
Modified
02/10/2020

Description

An Incorrect Access Control vulnerability was found in Wikimedia MediaWiki 1.18.0 through 1.32.1. It is possible to bypass the limits on IP range blocks ($wgBlockCIDRLimit) by using the API. Fixed in 1.32.2, 1.31.2, 1.30.2 and 1.27.6.

Solution(s)

  • debian-upgrade-mediawiki

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;