Rapid7 Vulnerability & Exploit Database

Debian: CVE-2020-10684: ansible -- security update

Back to Search

Debian: CVE-2020-10684: ansible -- security update

Severity
4
CVSS
(AV:L/AC:L/Au:N/C:N/I:P/A:P)
Published
03/24/2020
Created
08/10/2021
Added
08/09/2021
Modified
08/20/2021

Description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Solution(s)

  • debian-upgrade-ansible

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;