Rapid7 Vulnerability & Exploit Database

Debian: CVE-2020-8086: prosody-modules -- security update

Back to Search

Debian: CVE-2020-8086: prosody-modules -- security update

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
01/28/2020
Created
02/04/2020
Added
02/03/2020
Modified
02/06/2020

Description

The mod_auth_ldap and mod_auth_ldap2 Community Modules through 2020-01-27 for Prosody incompletely verify the XMPP address passed to the is_admin() function. This grants remote entities admin-only functionality if their username matches the username of a local admin.

Solution(s)

  • debian-upgrade-prosody-modules

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;