Rapid7 Vulnerability & Exploit Database

Debian: CVE-2021-22930: nodejs -- security update

Back to Search

Debian: CVE-2021-22930: nodejs -- security update

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
10/07/2021
Created
10/07/2022
Added
10/07/2022
Modified
10/07/2022

Description

Node.js before 16.6.0, 14.17.4, and 12.22.4 is vulnerable to a use after free attack where an attacker might be able to exploit the memory corruption, to change process behavior.

Solution(s)

  • debian-upgrade-nodejs

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;