Rapid7 Vulnerability & Exploit Database

Debian: CVE-2021-3507: qemu -- security update

Back to Search

Debian: CVE-2021-3507: qemu -- security update

Severity
4
CVSS
(AV:L/AC:L/Au:N/C:P/I:N/A:P)
Published
05/06/2021
Created
09/06/2022
Added
09/06/2022
Modified
09/06/2022

Description

A heap buffer overflow was found in the floppy disk emulator of QEMU up to 6.0.0 (including). It could occur in fdctrl_transfer_handler() in hw/block/fdc.c while processing DMA read data transfers from the floppy drive to the guest system. A privileged guest user could use this flaw to crash the QEMU process on the host resulting in DoS scenario, or potential information leakage from the host memory.

Solution(s)

  • debian-upgrade-qemu

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;