Rapid7 Vulnerability & Exploit Database

Debian: CVE-2022-37797: lighttpd -- security update

Back to Search

Debian: CVE-2022-37797: lighttpd -- security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/12/2022
Created
10/04/2022
Added
10/04/2022
Modified
10/04/2022

Description

In lighttpd 1.4.65, mod_wstunnel does not initialize a handler function pointer if an invalid HTTP request (websocket handshake) is received. It leads to null pointer dereference which crashes the server. It could be used by an external attacker to cause denial of service condition.

Solution(s)

  • debian-upgrade-lighttpd

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;