Rapid7 Vulnerability & Exploit Database

Debian: CVE-2022-39842: linux, linux-5.10 -- security update

Back to Search

Debian: CVE-2022-39842: linux, linux-5.10 -- security update

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
09/05/2022
Created
10/03/2022
Added
10/03/2022
Modified
11/01/2022

Description

An issue was discovered in the Linux kernel before 5.19. In pxa3xx_gcu_write in drivers/video/fbdev/pxa3xx-gcu.c, the count parameter has a type conflict of size_t versus int, causing an integer overflow and bypassing the size check. After that, because it is used as the third argument to copy_from_user(), a heap overflow may occur.

Solution(s)

  • debian-upgrade-linux
  • debian-upgrade-linux-5-10

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;