Rapid7 Vulnerability & Exploit Database

F5 Networks: K13331647 (CVE-2019-13233): Linux kernel vulnerability CVE-2019-13233

Back to Search

F5 Networks: K13331647 (CVE-2019-13233): Linux kernel vulnerability CVE-2019-13233

Severity
4
CVSS
(AV:L/AC:M/Au:N/C:P/I:P/A:P)
Published
07/04/2019
Created
10/18/2019
Added
10/16/2019
Modified
08/28/2020

Description

In arch/x86/lib/insn-eval.c in the Linux kernel before 5.1.9, there is a use-after-free for access to an LDT entry because of a race condition between modify_ldt() and a #BR exception for an MPX bounds violation.

Solution(s)

  • f5-big-ip-upgrade-latest

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;