Rapid7 Vulnerability & Exploit Database

FreeBSD: VID-96EAB874-9C79-11E8-B34B-6CC21735F730 (CVE-2018-10915): PostgreSQL -- two vulnerabilities

Back to Search

FreeBSD: VID-96EAB874-9C79-11E8-B34B-6CC21735F730 (CVE-2018-10915): PostgreSQL -- two vulnerabilities

Severity
6
CVSS
(AV:N/AC:M/Au:S/C:P/I:P/A:P)
Published
08/09/2018
Created
03/19/2019
Added
08/11/2018
Modified
05/07/2019

Description

A vulnerability was found in libpq, the default PostgreSQL client library where libpq failed to properly reset its internal state between connections. If an affected version of libpq was used with "host" or "hostaddr" connection parameters from untrusted input, attackers could bypass client-side connection security features, obtain access to higher privileged connections or potentially cause other impact through SQL injection, by causing the PQescape() functions to malfunction. Postgresql versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 are affected.

Solution(s)

  • freebsd-upgrade-package-postgresql10-server
  • freebsd-upgrade-package-postgresql93-server
  • freebsd-upgrade-package-postgresql94-server
  • freebsd-upgrade-package-postgresql95-server
  • freebsd-upgrade-package-postgresql96-server

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;