Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2002-1363: libpng: Buffer overflow on row buffers

Back to Search

Gentoo Linux: CVE-2002-1363: libpng: Buffer overflow on row buffers

Severity
8
CVSS
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Published
12/26/2002
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

Portable Network Graphics (PNG) library libpng 1.2.5 and earlier does not correctly calculate offsets, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a buffer overflow attack on the row buffers.

Solution(s)

  • gentoo-linux-upgrade-media-libs-libpng

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;