Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2008-6218: libpng: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2008-6218: libpng: Multiple vulnerabilities

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:N/I:N/A:C)
Published
02/20/2009
Created
07/25/2018
Added
10/30/2017
Modified
10/29/2021

Description

Memory leak in the png_handle_tEXt function in pngrutil.c in libpng before 1.2.33 rc02 and 1.4.0 beta36 allows context-dependent attackers to cause a denial of service (memory exhaustion) via a crafted PNG file.

Solution(s)

  • gentoo-linux-upgrade-app-antivirus-bitdefender-console
  • gentoo-linux-upgrade-app-arch-gzip
  • gentoo-linux-upgrade-app-arch-ncompress
  • gentoo-linux-upgrade-app-misc-beanstalkd
  • gentoo-linux-upgrade-app-text-dvipng
  • gentoo-linux-upgrade-app-text-gv
  • gentoo-linux-upgrade-dev-lang-tk
  • gentoo-linux-upgrade-dev-libs-liblzw
  • gentoo-linux-upgrade-dev-perl-perl-tk
  • gentoo-linux-upgrade-dev-util-insight
  • gentoo-linux-upgrade-dev-util-sourcenav
  • gentoo-linux-upgrade-kde-base-kdm
  • gentoo-linux-upgrade-kde-base-kget
  • gentoo-linux-upgrade-media-gfx-splashutils
  • gentoo-linux-upgrade-media-libs-libpng
  • gentoo-linux-upgrade-media-tv-dvbstreamer
  • gentoo-linux-upgrade-net-ftp-lftp
  • gentoo-linux-upgrade-net-mail-mlmmj
  • gentoo-linux-upgrade-net-misc-iputils
  • gentoo-linux-upgrade-sys-apps-acl
  • gentoo-linux-upgrade-sys-apps-pmount
  • gentoo-linux-upgrade-sys-auth-pam_krb5
  • gentoo-linux-upgrade-sys-block-partimage
  • gentoo-linux-upgrade-sys-devel-m4
  • gentoo-linux-upgrade-www-client-uzbl
  • gentoo-linux-upgrade-x11-apps-xinit
  • gentoo-linux-upgrade-x11-libs-gtk
  • gentoo-linux-upgrade-x11-misc-slim

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;