Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2009-2948: Samba: Multiple vulnerabilities

Back to Search

Gentoo Linux: CVE-2009-2948: Samba: Multiple vulnerabilities

Severity
2
CVSS
(AV:L/AC:M/Au:N/C:P/I:N/A:N)
Published
10/07/2009
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

mount.cifs in Samba 3.0 before 3.0.37, 3.2 before 3.2.15, 3.3 before 3.3.8 and 3.4 before 3.4.2, when mount.cifs is installed suid root, does not properly enforce permissions, which allows local users to read part of the credentials file and obtain the password by specifying the path to the credentials file and using the --verbose or -v option.

Solution(s)

  • gentoo-linux-upgrade-net-fs-samba

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;