Rapid7 Vulnerability & Exploit Database

Gentoo Linux: CVE-2009-3490: Wget: Certificate validation error

Back to Search

Gentoo Linux: CVE-2009-3490: Wget: Certificate validation error

Severity
7
CVSS
(AV:N/AC:M/Au:N/C:P/I:P/A:P)
Published
09/30/2009
Created
07/25/2018
Added
10/30/2017
Modified
10/30/2017

Description

GNU Wget before 1.12 does not properly handle a '\0' character in a domain name in the Common Name field of an X.509 certificate, which allows man-in-the-middle remote attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.

Solution(s)

  • gentoo-linux-upgrade-net-misc-wget

With Rapid7 live dashboards, I have a clear view of all the assets on my network, which ones can be exploited, and what I need to do in order to reduce the risk in my environment in real-time. No other tool gives us that kind of value and insight.

– Scott Cheney, Manager of Information Security, Sierra View Medical Center

;